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Typographic Conventions

Table 1

N

<Example>

Angle brackets indicate that you replace these words or characters with appropriate entries
to make entries in the system, for example, “Enter your <User Name>".

|+ Example » Example 3

Arrows separating the parts of a navigation path, for example, menu options

Example

Emphasized words or expressions

Example

Words or characters that you enter in the system exactly as they appear in the
documentation

Www.sap.com

Textual cross-references to an internet address

/example Quicklinks added to the internet address of a homepage to enable quick access to specific
content on the Web
123456 Hyperlink to an SAP Note, for example, SAP Note 123456
Example e Words or characters quoted from the screen. These include field labels, screen titles,
pushbutton labels, menu names, and menu options.
® (Cross-references to other documentation or published works
Example ®  Qutput onthe screen following a user action, for example, messages
®  Source code or syntax quoted directly from a program
® File and directory names and their paths, names of variables and parameters, and
names of installation, upgrade, and database tools
EXAMPLE Technical names of system objects. These include report names, program names,

transaction codes, database table names, and key concepts of a programming language
when they are surrounded by body text, for example, SELECT and INCLUDE

Keys on the keyboard

CUSTOMER

© Copyright 2015 SAP SE or an SAP affiliate company. ©
Copyright 2015 SAP SE or an SAP affiliate company. SAP Customer Activity Repository 2.0 SPO1

All rights reserved.All rights reserved. Typographic Conventions


http://www.sap.com
http://service.sap.com/~form/handler?_APP=01100107900000000342&_EVENT=REDIR&_NNUM=123456&_NLANG=en&_NVERS=0
http://service.sap.com/~form/handler?_APP=01100107900000000342&_EVENT=REDIR&_NNUM=123456&_NLANG=en&_NVERS=0

Content

1 Introduction . ..... ... . i i i i e s e e e e
11 About this Document . .. . ..
1.2 Before You Start . . . ...
Naming Conventions . . . . . ... . ..
Information Available on SAP Service Marketplace .. ... ... .. .. . .. ... .. .. .. ... .....
SAP Notes forthe Upgrade . . ... .. . . .
2 Quick GUIde .. ...ttt i i s a e e e e s a e
3 Prerequisites .. ....... .ttt s e s e e e s
4 Upgrade Process . ... ... oiii it ii it e inta e ansn e anansa s ananansnsannnnnsnns
4.1 Install SAP Customer Activity Repository Retail ApplicationsBundle ... .....................
4.2 Install ABAP Front-End Server (Optional) . ... ... . . . . . . . .
Install SAP NetWeaver Gateway on the ABAP Front-End Server ... ... ... ... .. .. ... .....
Install Central SAP Fiori Ul Components . . ... ... . .
Install the SAP Smart Business Modeler Apps Framework .. ... ... ... ... ... ... . ... ...
Install Product-Specific SAP Fiori Ul Components .. ... ... . . .. . .. . . . ...
5 Follow-Up Activities . ........ .. it i it i e e nanasannanannannsnnns
51 Create SAPERP Tables . .. . ..
5.2 Activate SAP HANA Content for SAP Customer Activity Repository .. ......... ... .. ... ......
53 Replicate Master Data Tables . . . . .. ..
Replicate SAP ERP Tables for SAP Customer Activity Repository . .......... ... ... ... ...
5.4 Configure SAP Smart Business for Multichannel Sales Analytics (Optional) .. .................
Activate SAP HANA Content for SAP Smart Business for Multichannel Sales Analytics
(Optional) . ..
Configure SAP NetWeaver Gateway . ... .. .. .. . .
Configure the SAP Web Dispatcher ... ... . .
Configure Central Ul Component . ... ...
Configure SAP Jam (Optional) . ... . . .
55 Install and Configure On-Shelf Availability (Optional) .. .. ... .. ... .. ... ... ... ... ........
Install the Application Function Library . . ... ... . . .
Generate Run IDs for OSA Processing Steps . .. . ..o
Check Field Contents in SAP HANA Content for On-Shelf Availability . .....................
Activate SAP HANA Content for On-Shelf Availability .. ... ... .. ... ... . . . .. .. ... . ...
Verify that SAP HANA Content for On-Shelf Availability has been activated . ... .......... ...
Configure SAP NetWeaver Gateway and Activate OData Service ... ......................
CUSTOMER
© Copyright 2015 SAP SE or an SAP affiliate company. ©
SAP Customer Activity Repository 2.0 SPO1 Copyright 2015 SAP SE or an SAP affiliate company.
Content All rights reserved.All rights reserved.



CUSTOMER

© Copyright 2015 SAP SE or an SAP affiliate company. ©

Copyright 2015 SAP SE or an SAP affiliate company.

All rights reserved.All rights reserved. SAP Customer Activity Repository 2.0 SPO1



1 Introduction

This guide provides technical information about upgrading SAP Customer Activity Repository 1.0 to SAP
Customer Activity Repository 2.0 SPOL.

SAP Customer Activity Repository is an add-on of SAP NetWeaver 7.40.

1.1 About this Document

This guide can be used by consultants and system administrators who intend to upgrade from SAP Customer
Activity Repository 1.0 to SAP Customer Activity Repository 2.0 SPOL. This guide does not describe the
installation of SAP HANA and SAP NetWeaver and does not provide information about the usage of upgrade or
installation tools.

1.2 Before You Start

The following sections provide information about:
® Naming Conventions
e |nformation on the SAP Service Marketplace
® SAP Notes for the Upgrade

1.2.1 Naming Conventions

Throughout this document the following naming conventions apply.

Terminology

SAP Customer Activity Repository is also referred to as the repository throughout this guide.

Due to the inconsistency of the names of their underlying technical objects, the names of the following business
objects are used interchangeably in this guide:

e Store: In most instances referred to as store, can also sometimes be referred to as plant or location.

® Article: In most instances referred to as article, can also sometimes be referred to as material or product.

Variables
Table 2
Variables Description
<SAPSID> ‘ SAP system ID in uppercase letters ‘
CUSTOMER
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<sapsid> SAP system ID in lowercase letters
<DBSID> Database ID in uppercase letters
<dbsid> Database ID in lowercase letters
<INSTDIR> Installation directory for the SAP system
<DVD_DIR> Directory on which a DVD is mounted
<0S> Operating system name within a path

1.2.2

More information is available as follows on SAP Service Marketplace.

Table 3: Documentation

Information Available on SAP Service Marketplace

Information on SAP Customer Activity
Repository.

| service.sap.com/instguides »
Industry Solutions ¥ Industry Solution
Guides » SAP for Retail » SAP Customer
Activity Repository 2

SAP Customer Activity Repository 2.0

Information on SAP Assortment
Planning for Retail.

| service.sap.com/instguides »
Industry Solutions  Industry Solution
Guides » SAP for Retail » SAP
Assortment Planning for Retail 3

SAP Assortment Planning for Retail 1.0

Information on SAP Promotion
Management for Retail.

|b service.sap.com/instguides »
Industry Solutions ¥ Industry Solution
Guides » SAP for Retail » SAP
Promotion Management for Retail 3

SAP Promotion Management for Retail
8.1

Information on the Demand Data
Foundation and Unified Demand
Forecast components in SAP Customer
Activity Repository.

| help.sap.com/car » Integration
Information 3

Administrator's Guide, Demand Data
Foundation (DDF) with Unified Demand
Forecast (UDF) on SAP HANA

Information on installing SAP HANA.

| help.sap.com/hana_platform »
Installation and Upgrade Information »
SAP HANA Server Installation and
Update Guide 3

SAP HANA Server Installation and
Update Guide (with or without SAP
HANA unified installer, based on your
SAP HANA SPS)

Information on installing SAP HANA
database clients.

| help.sap.com/hana_platform »
Installation and Upgrade Information »
SAP HANA Client Installation and Update
Guide 3

SAP HANA Client Installation and Update
Guide
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Information on installing SAP HANA
Studio.

|F help.sap.com/hana_platform »
Installation and Upgrade Information »
SAP HANA Studio Installation and
Update Guide 3

SAP HANA Studio Installation and
Update Guide

Information on implementing SAP
HANA Live for SAP Business Suite.

|F help.sap.com/hba # Installation,
Security, Configuration, and Operations
Information » Administrator’'s Guide 2

Administrator's Guide, SAP HANA Live
for SAP Business Suite

Information on installing the SAP LT
(Landscape Transformation)
Replication Server for SAP HANA.

|F help.sap.com/hana_platform »
Installation and Upgrade Information »
Installation Guide — Trigger-Based Data
Replication Using SAP LT Replication
Server for SAP HANA 3

Installation Guide - Trigger-Based Data
Replication Using SAP LT Replication
Server for SAP HANA

Information on managing major
operational aspects of the SAP LT
Replication Server.

I[P help.sap.com/hana_platform »
System Administration and Maintenance
Information » Application Operations
Guide - Trigger-Based Data Replication
Using SAP LT Replication Server for SAP
HANA 3

Application Operations Guide - Trigger-
Based Data Replication Using SAP LT
Replication Server for SAP HANA

Information on using SAP HANA.

¢ help.sap.com/hana_platform »
System Administration and Maintenance
Information » SAP HANA Administration
Guides 3

SAP HANA Administration Guide

Information for developers on how to |F help.sap.com/hana_platform » SAP HANA Developer Guide
use the SAP HANA development tools | Development Information » SAP HANA

to create comprehensive analytical Developer Guide 3

models and to build applications with

SAP HANA's interfaces and integrated

development.

Information for modelers (or business | [ help.sap.com/hana_platform » SAP HANA Modeling Guide

analysts) on how to define data models
that will be used in SAP HANA.

Modeling Information » SAP HANA
Modeling Guide 3

Information on installing SAP Solution
Manager.

|F help.sap.com/solutionmanager71 »
Installation and Upgrade Information »
Installation Guide 3

|F help.sap.com/nw74 ¥ Installation and
Upgrade Information » Master Guide 3

Master Guide, SAP NetWeaver 7.4

Information on installing SAP
NetWeaver 7.40.

|F help.sap.com/nw74 ¥ Installation and
Upgrade Information ¥ Installation
Guides » SAP HANA Database 3

Installation Guide, SAP Systems Based
on the Application Server <Your Server>
of SAP NetWeaver on <Your Operating
System>: SAP HANA Database

SAP Customer Activity Repository 2.0 SPO1
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Information on installing SAPERP 6.0 | [ help.sap.com/erp605 » Installation | Installation Guide, SAP ERP 6.0

Enhancement Package 5. and Upgrade Information ¥ Installation | Including SAP Enhancement Package 5 -
Guide 3 Technical Usage “Central Applications”
<Your Server>on <Your Operating
System>
Information on installing SAP | help.sap.com/crm702 » Installation | Installation Guide, SAP Customer

Enhancement Package 2 for SAP CRM | and Upgrade Information ¥ Installation | Relationship Management 7.0 Including
7.0 or SAP Enhancement Package 2 for | Guide ¥ Install ¥ Installation Guides for | Enhancement Package 2 Java and ABAP

SAP CRM 7.0, Version for SAP HANA or | SAP EHP 2 for SAP CRM 7.0 Administrator's Guide, SAP

higher. Installation Guide - SAP enhancement Enhancement Package 2 for SAP CRM
package 2 for CRM 7.0 - ABAP and 7.0, Version for SAP HANA
Java 1

|F help.sap.com/crmhana » Installation
and Upgrade Information »
Administrator’s Guide » Administrator's
Guide SAP CRM 7.0 EHP2, Version for
SAP HANA 3

Table 4: General Quick Links

SAP Help Portal help.sap.com

SAP Notes service.sap.com/notes

SAP Software Download Center support.sap.com/swdc

Released platforms and operating systems service.sap.com/platforms
System sizing service.sap.com/sizing

Security service.sap.com/security

SAP Solution Manager support.sap.com/solutionmanager

1.2.3 SAP Notes for the Upgrade

The following list includes SAP Notes that you must read (and, when appropriate, implement) before you start the
upgrade.

Make sure that you have the up-to-date version of each SAP Note, which you can find on SAP Service Marketplace
at service.sap.com/notes.

Table 5: SAP Notes for SAP Customer Activity Repository

1605140 SAP HANA 1.0: Central Note - SAP LT | Collective note for all the relevant SAP Notes for
Replication Server LT Replication Server for SAP HANA.
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What to consider when implementing SAP HANA

1778607 SAP HANA Live for SAP Business
Suite Live for SAP Business Suite.
1791342 Time Zone Support in SAP HANA How to handle time zone functions UTCTOLOCAL

and LOCALTOUTC.

SAP Customer Activity Repository 2.0 SPO1
Introduction
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2 Quick Guide

This section includes a checklist with all actions you have to perform. The actions are in chronological order, so

that you can work through them like a checklist.

Checklist

Prerequisites

Mandatory Steps

0O e Update the SAP HANA database of your system to SPS 08 revision 83 or higher.

0O e Update SAP NetWeaver to version 7.4 SPQO9.

Optional Steps
0O e Update SAP HANA Live for SAP ERP to SP 02 or higher.

O e Install the AFL for Unified Demand Forecast.
0O e Install the AFL for On-Shelf Availability.
O e Install SAP Jam, enterprise edition.

Upgrade Process

Mandatory Steps
0O e Upgrade your product version in SAP Solution Manager.
Optional Steps

0O e Install product-specific SAP Fiori Ul components.

Follow-Up Activities

Mandatory Steps
0O e Activate the SAP HANA content.

O e Replicate the new SAP ERP tables for SAP Customer Activity Repository.

O e Generate time data.

Optional Steps

0O e Configure SAP Smart Business for Multichannel Sales Analytics.
O e Configure On-Shelf Availability.

0O e Configure Demand Data Foundation.

0 e Complete setup of Unified Demand Forecast.
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3 Prerequisites

This section contains a list of all the prerequisite platforms, applications, and components that must be installed
and configured prior to executing the installation instructions covered in this guide.

1 Note

Installation of the following prerequisites should be performed by an experienced SAP Basis administrator.
Documentation and support for each prerequisite is available on the SAP Help Portal and the SAP Service
Marketplace.

The following table presents the prerequisites for each of the installation scenarios and provides links to the
respective installation documentation:

Table 6

Prerequisite Installation Information Mandatory/Optional for Scenario

SAP SAP SAP
Customer Assortment Promotion
Activity Planning for | Management
Repository Retail for Retail

SAP HANA Platform SPS08 | ® |p help.sap.com/hana_platform » Mandatory Mandatory Mandatory

revision 83 or higher Installation and Upgrade

The PAL algorithms, used by Information » SAP HANA Server
SAP Assortment Planning for Installation and Update Guide 3
Retail, are implemented and ® | help.sap.com/hana_platform ¥
shipped as an application Reference Information » SAP HANA
function library (AFL) in the Library References » SAP HANA
SAP HANA database. Predictive Analysis Library (PAL) 3
You have to ensure that SAP

HANA AFL 1.0 (software

component version SAP
HANA AFL 1.0)hasbeen

installed as part of your SAP
HANA Platform.

A Caution

If you were previously
using SAP HANA Platform
SP 07 or lower, and are
upgrading to SAP HANA

Platform SPS 08 or higher,
you need to implement
SAP Note 2022080.
CUSTOMER
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Mandatory/Optional for Scenario

Prerequisite

Installation Information

SAP SAP SAP
Customer Assortment Promotion
Activity Planning for | Management
Repository Retail for Retail

Demand Data Foundation e  SAP Note 2001688 Optional Mandatory Mandatory

(DDF) 2.0 SPO1 ® |k help.sap.com/car » Integration

A cross-industry reusable Information » Administrator's Guide,

data layer supporting Demand Data Foundation (DDF) with

different consuming Unified Demand Forecast (UDF) on

applications. DDF (software SAP HANA 3

component version RTLDDF

200) is acomponent in SAP

Customer Activity Repository

and a prerequisite for using

Unified Demand Forecast

(UDF).

UDF AFL revision 83 or ®  SAP Note 2050229 Optional Optional Recommende

higher e SAP Note 2004952 d

The Unified Demand Forecast

application function library A Caution

provides the demand There are dependencies between the

modeling and forecasting UDF AFL, the SAP HANA database, and

services in SAP Customer DDF. For more information, see the

Activity Repository. The UDF | Component Version Dependencies

AFL (software component section in the Administrator's Guide,

version UDFAFL_INST Demand Data Foundation (DDF) with

100) is shipped separately for | Unified Demand Forecast (UDF) on SAP

installation in the SAP HANA HANA for this support package.

database. The releases are

called “revisions”. The UDF

AFL requires Demand Data

Foundation (DDF) as a

prerequisite.

POS AFL (OSA) revision 83 e  SAP Note 2004952 Optional Optional Optional

or higher e SAP Note 2016825

The On-Shelf Availability

(OSA) algorithms (software

component version

POSAFL INST 10 0)are

implemented and shipped as

a separate application

function library (AFL) for

installation in the SAP HANA

database.
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Mandatory/Optional for Scenario

Prerequisite Installation Information

SAP SAP SAP
Customer Assortment Promotion
Activity Planning for | Management
Repository Retail for Retail
SAP Smart Business SAP Note 2018360 Optional Not Applicable | Not Applicable
foundation component 1.0
SPSO1
SAP LT (Landscape | help.sap.com/hana_platform » Mandatory Mandatory Not Applicable
Transformation) Replication | installation and Upgrade Information »
Server for SAP HANA 2.0 SAP HANA Replication Installation
Guides » Installation Guide — Trigger-
Based Data Replication Using SAP LT
Replication Server for SAP HANA 3
SAP Solution Manager ® |k help.sap.com/ Mandatory Mandatory Mandatory
We recommend to always use solutionmanager71 » Installation and
the latest version of the SAP Upgrade Information ¥ Installation
Solution Manager. Failure to Guide 3.
do so may cause problems ® |k help.sap.com/nw74 ¥ Installation
when using the Maintenance and Upgrade Information » Master
Optimizer (MOPZ) Guide 3.
application.
SAP NetWeaver 7.40 SP 09 | | help.sap.com/nw74 } Installation and Mandatory Mandatory Mandatory
If you launch WebDynpro Upgrade Information » Installation
applications from the back- | Guides 3
end system, ensure that you
have installed the SAP_UI 740
SP 11 component. If you have
a lower version, ensure that
you analyze and implement
SAP Note 2038829.
SAP ERP 6.0 ® |p help.sap.com/erp605 » Enhancement | Enhancement | Enhancement
See adjacent columns for Installation and Upgrade Package 5is | Package5is Package 5is
details regarding Information ¥ Installation Guide 3 mandatory mandatory. mandatory.
Enhancement Package ® |p help.sap.com/erp604 » when
version support. Installation and Upgrade implementing
Information ¥ Installation Guide 3 SAP
Customer
®  SAP Notes (applicable only for SAP Activity
ERP 6.0 EHP5 and higher): Repository
o 1983853 with DDF with
o 1994823 UDF.
o 2004326 Otherwise,
Enhancement
o 2032294 Package 4 is
o 2069483
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Prerequisite

Installation Information

o 2068874

Mandatory/Optional for Scenario

SAP
Customer
Activity
Repository

mandatory at
abare
minimum if
not
implementing
DDF with UDF.

SAP
Assortment
Planning for
Retail

SAP

Promotion
Management

for Retail

SAP Enhancement Package
2 for SAP CRM 7.0 or SAP
Enhancement Package 2 for
SAP CRM 7.0, Version for
SAP HANA or higher

® |p help.sap.com/crm702 »
Installation and Upgrade
Information ¥ Installation Guide 3

® |k help.sap.com/crmhana »
Installation and Upgrade
Information » Administrator’s
Guide 3

Optional

Not Applicable

Not Applicable

SAP HANA Live for SAP ERP
SP 02 or higher

A Caution

SAP Customer Activity
Repository retail
applications bundle does
not require that you
execute all of the
installation steps exactly
as they are described in
the Administrator's Guide,
SAP HANA Live for SAP
Business Suite.

You must read the Install
SAP HANA Live for SAP
ERP procedure in this
guide prior to installing
SAP HANA Live for SAP
ERP.

|F help.sap.com/hba » Installation,
Security, Configuration, and Operations
Information » Administrator’s Guide 2

Mandatory

Mandatory

Not Applicable

Client

To be able to run SAP Fiori
apps, the runtime
environment (such as the
browser) of the client must
support HTML5.

Client-specific installation information

Optional

Mandatory

Not Applicable
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Prerequisite Installation Information Mandatory/Optional for Scenario
SAP SAP SAP
Customer Assortment Promotion
Activity Planning for | Management
Repository Retail for Retail

SAP BusinessObjects | help.sap.com/boao # Installation, Not Applicable | Mandatory Not Applicable

Analysis, edition for Security, Configuration, and Operations

Microsoft Office 1.4 SP 09 or | Information » Administrator's Guide 3

higher

SAP Assortment Planning for
Retail includes a number of
SAP BusinessObijects
Analysis workbooks. To be
able to access assortment
planning workbooks, you
must ensure that SAP
BusinessObjects Analysis,
edition for Microsoft Office 1.4
SP 09 or higher is installed on
your local system.

SAP Jam, enterprise edition | |p help.sap.com/sapjam » System Optional Optional Not Applicable
Administration and Maintenance
Information » Administrator’s Guide 3
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4 Upgrade Process

4.1 Install SAP Customer Activity Repository Retail
Applications Bundle

We recommend using Maintenance Optimizer in SAP Solution Manager to install and update product versions.
SAP Solution Manager calculates the required software components that have to be deployed on each server.

For more information about Maintenance Optimizer, see SAP Help Portal at |p help.sap.com/
solutionmanager71 » Application Help » SAP Library » SAP Solution Manager » Maintenance Management »
Maintenance Optimizer 1.

Alternatively, you can download the required files directly from SAP Service Marketplace and deploy them
manually.

In this procedure, you use Maintenance Optimizer to perform a stack XML installation of SAP Customer Activity
Repository retail applications bundle 1.0.

Procedure

1. Logonto SAP Solution Manager and launch Maintenance Optimizer.

For more information on using Maintenance Optimizer, see |F service.sap.com/mopz 1.

1 Note

Maintenance Optimizer 3.0 (MOPZ) is the standard for SAP Solution Manager 7.1 SP12. You may
experience difficulties installing products if you are running an older version of SAP Solution Manager.

We recommend upgrading to the latest version of SAP Solution Manager. If you do not wish to do so, you
must implement SAP Note 1940845 to render the MOPZ front-end compatible with the back-end.

2. Inthe Maintenance Optimizer work step that allows you to choose add-on products, select product version
CAR RETAIL APPL BUNDLE 1.0 andproductinstance CARAB ABAP Server.

fw?-‘ CAR RETAIL APPL BUNDLE 1.0 01 (10/2014) ~ SAP Customer Aclivity Repository retail applications bundie 1.0
m CAR RETAIL APPL BUNDLE 1.0
Instance Required Instance Required Product Version Systems
|| CARAB ABAP Server Application Server ABAP SAP NETWEAVER 7.4 Assign System

Figure 1: Selection of Product Version and Product Instance

Caution

Do not deselect any ABAP components from the product instance.

3. Calculate and download the stack XML file.

4. Logon toyour back-end server, that is, the ABAP system on which you are installing CAR Retail Appl Bundle -
ABAP Instance.
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5. Use the SAP Add-On Installation Tool (transaction SAINT) to load and install the stack XML generated using
SAP Solution Manager Maintenance Optimizer.

For more information on transaction sSAINT, refer to the system documentation available directly in the
system when you run transaction SAINT and select the Online Help icon.

4.2 Install ABAP Front-End Server (Optional)

The following section only requires implementation if you plan on using the SAP Smart Business for Multichannel
Sales Analytics cockpit.

For more information, see SAP Help Portal at [ help.sap.com » Application Help » SAP Smart Business for SAP
Customer Activity Repository 1.

4.2.1 Install SAP NetWeaver Gateway on the ABAP Front-End
Server

The complete Ul layer consisting of the central Ul component, the product-specific Ul components and the SAP
NetWeaver Gateway is contained in the ABAP front-end server. SAP NetWeaver Gateway handles the
communication between the client and the ABAP back-end server. For a visualization of how these components
interact, see Overall System Planning [external document].

When you are implementing the Central Hub deployment option, you use separate servers for the back-end and
front-end components in your landscape.

Procedure

Ensure that the necessary SAP NetWeaver version is installed on your front-end server. For more information, see
SAP Library for SAP Fiori on SAP Help Portal at [» help.sap.com/fiori_bs2013 » System Landscape Required for
SAP Fiori » Setup of SAP Fiori System Landscape with SAP HANA Database » Installation 1.

4.2.2 Install Central SAP Fiori Ul Components

The complete Ul layer consisting of the central Ul component, the product-specific Ul components and the SAP
NetWeaver Gateway is contained in the ABAP front-end server. The central Ul component contains the SAP UI5
control library and the SAP Fiori Launchpad.

When you are implementing the Central Hub deployment option, you use separate servers for the back-end and
front-end components in your landscape. Your front-end server must have the required central Ul component
version.
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Procedure

Ensure that SAP_UI 740 SP11 (which contains SAPUI5 Version 1.24.2 or higher) or equivalent is installed on your
front-end server.

Depending on the version of SAP NetWeaver installed on your front-end server, the central Ul component is either
installed as an add-on (for example, for SAP EhP1 for SAP NetWeaver 7.3 or higher) or is integrated directly in the
SAP NetWeaver installation (for example, SAP NetWeaver 7.4 SPO4 or higher). In either case, to use the apps
delivered as part of SAP Fiori 1.0 for SAP Customer Activity Repository retail applications bundle (SAP FIORI
FOR SAP CARAB 1.0), SAP_UI 740 SP11 (which contains SAPUI5 Version 1.24.2 or higher) or equivalent must
be installed on your front-end server.

For more information, see SAP Library for SAP Fiori on SAP Help Portal at [» help.sap.com/fiori_bs2013 » System
Landscape Required for SAP Fiori » Setup of SAP Fiori System Landscape with SAP HANA Database »
Installation » Setup of Front-End Server » Installation of Central Ul Components 1.

4.2.3 Install the SAP Smart Business Modeler Apps
Framework

The SAP Smart Business for Multichannel Sales Analytics apps included in this installation are based on the SAP
Smart Business Modeler Apps Framework. Installation and setup of this framework includes the following:

® |nstallation of SAP Smart Business Modeler apps on the front-end server
® |nstallation of SAP Smart Business products on the SAP HANA Server

® |nstallation of SAP Web Dispatcher

e Communication channels

® Appimplementation

For more information on these topics, see |k help.sap.com/nw74 » Application Help » Ul Technologies in SAP
NetWeaver » Ul Frameworks based on HTML5, JavaScript and CSS » SAPUI5 Application Frameworks » SAP
Smart Business » Setting up the SAP Smart Business Modeler Apps Framework 3.

4.2.4 Install Product-Specific SAP Fiori Ul Components

The complete Ul layer consisting of the central Ul component, the product-specific Ul components and the SAP
Gateway is contained in the ABAP front-end server. The product-specific Ul component contains the SAP Fiori
user interface for the SAP Assortment Planning for Retail application and the SAP Smart Business for SAP
Customer Activity Repository. This procedure describes the installation of this product-specific Ul component.

Procedure

1. Logonto SAP Solution Manager and launch Maintenance Optimizer.

For more information about using Maintenance Optimizer, see [F service.sap.com/mopz 1.
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1 Note

Maintenance Optimizer 3.0 (MOPZ) is the standard for SAP Solution Manager 7.1 SP12. You may
experience difficulties installing products if you are running an older version of SAP Solution Manager.

We recommend upgrading to the latest version of SAP Solution Manager. If you do not wish to do so, you
must implement SAP Note 1940845 to render the MOPZ front-end compatible with the back-end.

2. Inthe Maintenance Optimizer work step that allows you to choose add-on products, select product version
SAP FIORI FOR SAP CARAB 1.0.

3. Select the product instance based on the SAP NetWeaver version of your front-end server:
o Ul for SAP CARAB on NW 740
o Ul for SAP CARAB on NW 731
Calculate and download the stack XML file.
Log on to your front-end server.
Use the SAP Add-On Installation Tool (transaction SAINT) to load and install the stack XML generated using
SAP Solution Manager Maintenance Optimizer.
For more information on transaction SAINT, refer to the system documentation available directly in the
system when you run transaction SAINT and select the Online Help icon.
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5 Follow-Up Activities

5.1 Create SAP ERP Tables

In this section you must create the new SAP ERP tables that are required for SAP Customer Activity Repository
2.0. Create these tables using the instructions provided in SAP Note 1900038.

1 Note

The creation of these tables is required before proceeding with the upgrade. Failure to do so will result in SAP
HANA content activation and deployment failures.

5.2 Activate SAP HANA Content for SAP Customer Activity
Repository

In this procedure, you activate all SAP HANA content (SAP HANA views and SQLScript procedures) required by
SAP Customer Activity Repository.

For more information about activating SAP HANA content, see SAP Help Portal at [k help.sap.com/
hana_platform » Development Information » SAP HANA Developer Guide » Setting Up the Analytic Model »
Creating Views » Activating Objects 1.

Prerequisites

As a mandatory prerequisite for a successful activation of the SAP HANA content for SAP Customer Activity
Repository, you must have successfully completed all of the procedures listed in the previous sections of this
guide.

Procedure

1. Ensurethatthe sysS REPO user has the authorizations required to successfully activate SAP HANA content.

1. Provideuser sys REPO with object privilege SELECT, with option "Grantable to others", on the following
physical DB schemas:

©  Physical database schema of your back-end system, typically this is called SAP<SID>.
o Physical database schema that contains the SAP ERP tables

o Physical database schema that contains the SAP CRM tables

You can use the following example SQL statement to grant the required privilege:

GRANT SELECT ON <Your schema name> TO _SYS REPO WITH GRANT OPTION;
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2. Assign the required privileges described in [ help.sap.com/car » Integration Information »
Administrator’s Guide, Demand Data Foundation (DDF) with Unified Demand Forecast (UDF) on SAP
HANA » Authorization Requirements for Unified Demand Forecast (UDF) 1.

2. Usetransaction SE38 to run program /CAR/ACTIVATE HANA CONTENT.

The program activates all SAP HANA content required by SAP Customer Activity Repository. Note that this
includes the SAP HANA content for DDF and UDF.

Log on to SAP HANA studio.
Open the Modeler perspective and use the Navigator to access your back-end system.

Expand the Content folder located under your system name in the Navigator.

o o A~ W

Expand each of the packages listed below and ensure that all the content in the underlying folders is active:
O sap.is.ddf

O sap.is.udf

O sap.is.retail.car

O sap.is.retail.ecc

O sap.is.retail.posdm

O sap.is.retail.syndication

5.3 Replicate Master Data Tables

In your previous installation of SAP Customer Activity Repository, you set up replication of master data tables. In
this section, you replicate and add new tables that are included in the upgrade to SAP Customer Activity
Repository 2.0.

Since you are already running a previous version of SAP Customer Activity Repository, you have already set up
replication for some of the tables required. In this section you should identify the additional tables that you must
replicate and add only these to your existing replication setup.

For the complete list of SAP ERP tables to replicate, see SAP Note 1897024.

5.3.1 Replicate SAP ERP Tables for SAP Customer Activity
Repository

In this procedure, you ensure that all SAP ERP tables that are relevant for SAP Customer Activity Repository have
not only been created but have also been filled with data. More specifically, you replicate the contents of relevant
tables from the source SAP ERP system to your back-end system.

The steps outlined in this procedure are required when you are implementing one of the SAP Customer Activity
Repository system landscape variants that require data to be replicated from a source SAP ERP system. If your
source SAP ERP system and the repository are co-deployed on the same SAP HANA database, proceed to the
next procedure. For more information, see System Landscape Variants [external document].

CUSTOMER

© Copyright 2015 SAP SE or an SAP affiliate company. ©

SAP Customer Activity Repository 2.0 SPO1 Copyright 2015 SAP SE or an SAP affiliate company.
Follow-Up Activities All rights reserved.All rights reserved. 23


http://help.sap.com/car
http://service.sap.com/~form/handler?_APP=01100107900000000342&_EVENT=REDIR&_NNUM=1897024&_NLANG=en&_NVERS=0

Procedure

24

Define client transformation rules for all SAP ERP tables that you plan to replicate.

In most cases, you need to apply transformation rules to map the client of the source SAP ERP system to the
client on the target SAP Customer Activity Repository system.

Caution

Transformation rules must be defined prior to replicating tables.

For more information, refer to one of the following:
o Set Up SAP Client [external document]

© |» help.sap.com/hana_platform » System Administration and Maintenance Information » Application
Operations Guide — Trigger-Based Data Replication Using SAP LT Replication Server for SAP HANA » Data
Transformation Capabilities within SAP Landscape Transformation Replication Server 31

©  SAP Note 1733714
Specify which SAP ERP tables to replicate.

We recommend that you only replicate data for SAP ERP tables that are relevant to SAP Customer Activity
Repository. Read SAP Note 1897024 and replicate only the tables listed in the file attached to this SAP Note.

However, if you are planning to use all of SAP HANA Live for SAP ERP views, then replicate all the tables
listed in the file attached to SAP Note 1781992.

For more information, see:

o |» help.sap.com/hba » Installation, Security, Configuration, and Operations Information » Administrator's
Guide » Administrator's Guide, SAP HANA Live for SAP Business Suite » Configuration Steps » Replicate
Data (Side-by-Side Only) 2

o |p help.sap.com/hana_platform » System Administration and Maintenance Information » Application
Operations Guide — Trigger-Based Data Replication Using SAP LT Replication Server for SAP HANA »
(<Managing the Replication Process Using the SAP HANA Studio> and <Important Transactions and
Control Tables>) » 3

Caution

This procedure includes the replication of tables from your source SAP ERP system. Trigger-based
replication includes deletion in source tables by archiving activities (since on the database level it is
impossible to distinguish between delete actions caused by archiving and regular deletion of data records).
As aresult, SAP LT (Landscape Transformation) Replication Server replicates archiving activities as delete
actions in the SAP HANA database.

More specifically, when data is archived in your source SAP ERP system, records are deleted from their
respective database tables. Therefore, when these tables are replicated to another SAP HANA database,
the records that were archived in the source tables are deleted in the target database tables.

For example, sales document data is set up to be replicated from your source SAP ERP system to your
target SAP HANA database. You may have set up your SAP ERP system to archive sales documents that
are more than a year old. Given the SAP ERP archiving settings, in the SAP Customer Activity Repository
system, you will not be able to run analytic reports on multichannel transaction data (which includes
replicated SAP ERP sales documents) that is more than a year old.

When deciding on the frequency at which to archive data in the source SAP ERP system, you must consider
and balance the performance requirements of your SAP ERP system and the amount of historical data that
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must be available in the SAP Customer Activity Repository system for analysis. The general
recommendation is that 18 to 24 months of historical sales data is available in the repository.

5.4 Configure SAP Smart Business for Multichannel Sales
Analytics (Optional)

5.4.1 Activate SAP HANA Content for SAP Smart Business
for Multichannel Sales Analytics (Optional)

In this procedure, you activate all SAP HANA content required by the SAP Smart Business for Multichannel Sales
Analytics dashboards.

Prerequisites

You have completed activating all SAP HANA content (SAP HANA views and SQLScript procedures) required by
SAP Customer Activity Repository.

For more information, see Activate SAP HANA Content for SAP Customer Activity Repository [page 22].

Procedure
1. Logontothe ABAP instance of the SAP Customer Activity Repository system.
2. Execute transaction SE38.
3. Specify SNHI NHDU POST PROCESS in the Program field and choose Execute.
4. Ifyou are running SAP NetWeaver 7.4 SPO5 or higher, make the following entries:
Table 7
Transport Container Name /CAR/HCO_RTLCAR MCSA
Activate Delivery Unit Content Select the checkbox.
Activate HTC Do not select the checkbox.

5. Choose Execute.

All objects belonging to the delivery unit will be activated in the SAP HANA repository. This process can take
several minutes. Once the activation process is complete, you are notified whether or not the import and
activation of the SAP HANA delivery unit was successful.
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5.4.2 Configure SAP NetWeaver Gateway

5.421 Perform General SAP Gateway Configuration

Prior to connecting the SAP Gateway on your front-end server to your back-end system, you need to perform a
series of general SAP Gateway configuration steps. These configuration steps include the setting of profile
parameters, ICF (Internet Communication Framework) services, language settings, and so on.

These steps are not specific to this installation guide and are described in the SAP NetWeaver product
documentation referenced below.

Procedure

1. Determine the SAP NetWeaver version on your front-end server.
2. Carry out the instructions specific to your SAP NetWeaver version:
o SAP Gateway for SAP NetWeaver 7.31

See|p help.sap.com/nwgateway?0 » Application Help » SAP NetWeaver Gateway » SAP NetWeaver
Gateway Configuration Guide » Basic Configuration Settings 1.

o  SAP Gateway for SAP NetWeaver 7.40

See | help.sap.com/nw74 » Application Help » Function-Oriented View » SAP NetWeaver Gateway
Foundation (SAP_GWFND) » SAP NetWeaver Gateway Foundation Configuration Guide » Basic
Configuration Settings 1.

5.4.2.2 Connect SAP Gateway to your Back-End System

In this procedure, you configure the OData channel, that is, set up a connection between SAP Gateway on your
front-end server and your back-end system.

These steps are not specific to this installation guide and are described in the SAP NetWeaver product
documentation referenced below.

Procedure

1. Setupthe required roles on the front-end server and assign your user to these roles.

For more information, see [k help.sap.com/nw74 » Application Help » Function-Oriented View » SAP
NetWeaver Gateway Foundation (SAP_GWFND) » SAP NetWeaver Gateway Foundation Configuration
Guide » OData Channel Configuration » User, Developer and Administrator Authorizations 1.

2. Specify the connection settings on the SAP Gateway hub system, which include:
o Connection from the SAP Gateway to consumer systems

These settings allow the connection between the SAP Gateway host and the consumer systems (clients
from which you access the SAP Fiori user interfaces.)

o Connection from the SAP Gateway to SAP back-end system

CUSTOMER

© Copyright 2015 SAP SE or an SAP affiliate company. ©

Copyright 2015 SAP SE or an SAP affiliate company. SAP Customer Activity Repository 2.0 SPO1
26 All rights reserved.All rights reserved. Follow-Up Activities


http://help.sap.com/nwgateway20
http://help.sap.com/nw74
http://help.sap.com/nw74

These settings allow the connection between SAP Gateway to your back-end system.

These settings include:

o Creating a type 3 connection from the SAP Gateway host to your back-end system.

o Defining a trust relationship between your back-end system and the SAP Gateway host.

o Configuring your back-end system to accept SAP assertion tickets from the SAP Gateway host.
o Configuring your SAP Gateway host to accept SAP assertion tickets from your back-end system.

o Configure the necessary system aliases.

More Information

For SAP NetWeaver 7.31, see SAP Library for SAP NetWeaver Gateway on SAP Help Portal at [k help.sap.com/
nwgateway20 » Application Help » Support Package Stack » SAP NetWeaver Gateway » SAP NetWeaver Gateway
Configuration Guide » OData Channel Configuration » Connection Settings on the SAP NetWeaver Gateway Hub
System 1.

For SAP NetWeaver 7.4, see SAP Library for SAP NetWeaver on SAP Help Portal at|» help.sap.com/nw74 »
Application Help » Function-Oriented View » SAP NetWeaver Gateway Foundation (SAP_GWFND) » SAP
NetWeaver Gateway Foundation Configuration Guide » OData Channel Configuration » Connection Settings on the
SAP NetWeaver Gateway Hub System 1.

5.4.2.3 Activate SAP Gateway

Before you can use SAP Gateway functionality, you have to activate it globally on your front-end server.

These steps are not specific to this installation guide and are described in the SAP NetWeaver product
documentation referenced below.

Procedure

1. Determine the SAP NetWeaver version of your front-end server.
2. Carry out the instructions specific to your SAP NetWeaver version:

o For SAP NetWeaver 7.4, see SAP Help Portal at |» help.sap.com/nw74 » Application Help » Function-
Oriented View » SAP NetWeaver Gateway Foundation (SAP_GWFND) » SAP NetWeaver Gateway
Foundation Configuration Guide » OData Channel Configuration » Activating SAP NetWeaver Gateway 1.

o For SAP NetWeaver 7.31, see SAP Help Portal at |F help.sap.com/nwgateway20 » Application Help » SAP

NetWeaver Gateway Configuration Guide » SAP NetWeaver Gateway Configuration Guide » OData
Channel Configuration » Activating SAP NetWeaver Gateway 3.

54.2.4 Activate Common OData Services

A number of OData services are required to run the SAP Fiori Launchpad. These OData services are delivered with
the central Ul component (SAP_UI 740 SP11 orequivalent).
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For security reasons, all OData services are delivered in an inactive state. To use the SAP Fiori Launchpad, you
must activate the common SAP Fiori OData services.

Procedure

Log on to your front-end system (your SAP Gateway system).
Go to Customizing (transaction SPRO).

Navigate to [k SAP NetWeaver » Gateway » OData Channel » Administration » General Settings » Activate
and Maintain Services 1.

You are presented with the service catalog. This is a list of all the services that are currently active on your
SAP Gateway.

Get common SAP Fiori OData services:
1. Choose Add Service.
The Add Service screen is displayed.
2. Enter the system alias of your local front-end system.

This is the alias created in the Connect SAP NetWeaver Gateway to your Back-End System [page 26]
procedure. For example, LOCAL.

Enter /u12* in the Technical Service Name field.
4. Choose Get Services.
The Add Selected Services screen is displayed.

5. Select the common SAP Fiori OData services that you would like to activate, and choose Add Selected
Services.

Table 8

Service Name

/UI2/PAGE_BUILDER CONF

/UI2/PAGE_BUILDER CUST

/UI2/PAGE_BUILDER PERS

/UI2/TRANSPORT

/UI2/INTEROP

The selected OData services are now active in your SAP Gateway.

More Information

28

For SAP NetWeaver 7.31, see SAP Library for User Interface Add-On 1.0 on SAP Help Portal at
Ik help.sap.com/nw-uiaddon » Application Help ¥ User Interface Add-On for SAP NetWeaver » SAP Fiori
Launchpad » Setting Up the Launchpad » Activating SAP NetWeaver Gateway OData Services 1.

For SAP NetWeaver 7.4, see the documentation on SAP Help Portal at [» help.sap.com/nw74 » Application
Help » Ul Technologies in SAP NetWeaver » Ul Frameworks based on HTML5, JavaScript and CSS » SAP Fiori
Launchpad » Setting Up the Launchpad » Activating SAP NetWeaver Gateway OData Services 1.
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5.4.3 Configure the SAP Web Dispatcher

To configure the SAP Web Dispatcher, see SAP Help Portal at |p help.sap.com/nw_platform » Application Help »
Function-Oriented View » Application Server » Application Server Infrastructure » Components of SAP NetWeaver
Application Server » SAP Web Dispatcher » Administration of the SAP Web Dispatcher 1.

If you use any other reverse proxy, see the manufacturer’'s documentation for more information.

5.4.4 Configure Central Ul Component

The central Ul component (SAP_UI 740 sP11 or equivalent) contains the SAP UI5 control library and the SAP
Fiori Launchpad. Prior to being able to use the SAP Fiori apps that constitute the user interface of the retail
applications described in this guide, you may need to configure the SAP Fiori Launchpad.

These steps are not specific to this installation guide and are described in the SAP NetWeaver product
documentation referenced below.

Procedure

1. Determine the SAP NetWeaver version on your front-end server.
2. Carry out the instructions specific to your SAP NetWeaver version:
o SAP Gateway for SAP NetWeaver 7.31
o |» help.sap.com/nw-uiaddon » Application Help » SAP Fiori Launchpad 3, and

o |k help.sap.com/nw-uiaddon » Application Help » Administration Guide » Content Administration »
SAP Fiori Launchpage » Setting Up the SAP Fiori Launch Page 1.

o SAP Gateway for SAP NetWeaver 7.40

o |k help.sap.com/nw74 » Application Help » Ul Technologies in SAP NetWeaver » Ul Framework based
on HTML5, JavaScript and CSS » SAP Fiori Launchpad 3, and

o |p help.sap.com/nw74 » Application Help » Ul Technologies in SAP NetWeaver » Ul Framework based
on HTML5, JavaScript and CSS » SAP NetWeaver User Interface Services » Administration Guide »
Content Administration » SAP Fiori Launchpage » Setting Up the SAP Fiori Launch Page 1.

5.4.5 Configure SAP Jam (Optional)

Your retail application uses collaboration SAPUI5 components to define key ABAP-based SAP business object
data that can be consumed by SAP Jam.

If you are using the SAP Jam social collaboration platform in your business, you can configure the integration
between your retail application and SAP Jam. The integration, enabled by Social Media Integration, allows you to
share, or expose, the pre-defined ABAP-based SAP business object data directly from your retail application with
members of your organization, through SAP JAM.
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The steps to enable the integration between your retail application and SAP Jam are not specific to this
installation guide and are described in the User Interface Add-On 1.0 for SAP NetWeaver product documentation
referenced below.

Prerequisites

To enable the integration of your retail application with SAP Jam, you must have a license for SAP Jam Enterprise
edition and your SAP Jam instance must be configured for productive use.

Procedure

1. Readthe documentation for User Interface Add-On available on SAP Help Portal at [p help.sap.com/
netweaver » User Interface Add-On for SAP NetWeaver » Application Help » Social Media Integration 1.

This documentation provides important information on configuring the integration of your retail application
with SAP Jam, including:

o Understanding the Overall Process for Integrating Collaboration for a Business Object
© Implementation of ABAP Social Media Integration (ABAP SMI)

© Implementation of Collaboration SAPUI5 Components

o Connecting SAP Jam with ABAP SMI

o Configuring ABAP SMI for SAP Fiori Apps

More Information

For the latest updates on SAP Jam, see the SAP Help Portal at help.sap.com/sapjam.

5.5 Install and Configure On-Shelf Availability (Optional)

1 Note

The steps in this section and all subsections are entirely optional and depend on your specific implementation
requirements.

To use the On-Shelf Availability (OSA) functionality in SAP Customer Activity Repository, perform the following
post-installation steps.

5.5.1 Install the Application Function Library

The On-Shelf Availability (OSA) algorithms are implemented as a separate application function library (AFL) that
you install and run in the SAP HANA database. The AFL releases are called “revisions”. The AFL software
component version is POSAFL INST 100.
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For alist of the available revisions and for installation instructions, see SAP Note 2056102.

5.5.2 Generate Run IDs for OSA Processing Steps

Each scheduled run of an OSA processing step has a generated run ID. This is the unique identification for a job.
The run ID is used to distinguish several runs within one period. Each processing step has its own ID generator:

Table 9
Intraweek Pattern /OSA/NR_IWP
Estimation /OSA/NR_EST
Monitoring /OSA/NR_MON
Analysis /OSA/NR_ANA

For each of the four transactions, you must define the range of run IDs.

Procedure

1. Execute transaction /OSA/NR <XXX>. <XXX>represents the part of the transaction name that is specific for

a processing step.
2. Inthefirst row of the table, enter the following values for the fields No, From No. and To Number:
© No:01
©  From No.: 0000000000000001
©  ToNumber: 9999999999999999

5.5.3 Check Field Contents in SAP HANA Content for On-
Shelf Availability

There are two OSA-specific SAP HANA views that can be customized:
® AN TRANSACTION
e PROMOTION TRANS

You have to check if the fields in these views contain the mappings or formulas you need.

A Caution

If you need to modify any of the views, be aware, that new installation will rewrite the modifications. It is
therefore recommended to back up the modified views.
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Procedure

If you want to change the mapping or a formula of a field, perform the following steps:

1. Define the data foundation that is the source for the view, that is, the table /POSDW/TLOGF.
2. Define filters for the view.

3. Map the fields from source to target.

4. Create measures and calculation fields.

For detailed information, see [» help.sap.com/hana_appliance » Modeling Information 1.

Definitions for a view taking the example of the AN_TRANSACTION view

The following definitions are set by default for the AN TRANSACTION view:
® Source of the view is the table /POSDW/TLOGF
® Examples of filters for the views:
O RECORDQUALIFIER = '5':Only salesrecords are used

© DATASTATUS in ('2' , '3"):Onlythose records are used which passed the SAP Customer Activity
Repository validation

O RETAILQUANTITY > 0.0:Negative quantities are not used by On-Shelf Availability
© VOIDEDLINE = '':Cancelledtransactions are not used by On-Shelf Availability
® Examples of the fields mappings:
o MANDT: Client id. This field is mapped to the MANDT column of the /POSDW/TLOGF table.
© STORE_ID: Storeid. This field is mapped to the RETAILSTOREID column of the /POSDW/TLOGF table.

O BUSINESSDAYDATE: Business day. This field is mapped to the BUSINESSDAYDATE column of the /
POSDW/TLOGF table.

® [Examples of measures:

O RETAILQUANTITY: Amount of sold units. Refers to the saLESUOM (Sales Unit of Measure) field that is
also defined in the /POSDW/TLOGF table. Contains the value of the RETATLQUANTITY field.

O PRICE: Price specified in the store currency. Contains the value of the ACTUALUNITPRICE field.
e Examples of calculated fields:

© TRANS TIME DBL: Value of the TRANS TIME output field of type DOUBLE. The format of the transaction
time that is stored in BEGINTIMESTAMP and ENDTIMESTAMP is “YYYYMMDDhhmmss”.

© DISCOUNT: Total relative discount applied on the item.

Calculated as (ITEMDISC + DISTDISC) / (RETAILQUANTITY * ACTUALUNITPRICE). If the price is not
positive number, O is returned.

Definitions:
o DISTDISC: global discount on the whole purchase; currently not used.

© |ITEMDISC: item-specific discount; currently used.

5.5.4 Activate SAP HANA Content for On-Shelf Availability

In this procedure, you activate all SAP HANA content required by On-Shelf Availability.
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Procedure
1. Logon toyour back-end system.
2. Execute transaction SE38.
3. Specify SNHI NHDU POST PROCESS inthe Program field and choose Execute.
4. Ifyouare running SAP NetWeaver 7.4 SPO5 or higher, make the following entries:
Table 10
Transport Container Name /OSA/HCO_POSDMEXT
Activate Delivery Unit Content Select the checkbox.
Activate HTC Do not select the checkbox.

5. Choose Execute.

All objects belonging to the delivery unit will be activated in the SAP HANA repository. This process can take
several minutes. Once the activation process is complete, you are notified whether or not the import and
activation of the SAP HANA delivery unity was successful.

5.5.5 Verify that SAP HANA Content for On-Shelf Availability
has been activated

Procedure

Log on to SAP HANA studio.

Open the Modeler perspective.

In the Navigator window, expand the database system for which you have activated the views.
Expand the Content folder.

Expand the package hierarchy by choosing I sap » is » retail » posdmext » osa 1.

o 9 A w b=

Verify that the following views have been activated:

© sap.is.retail.posdmext.osa.tlog.an transaction

O sap.is.retail.posdmext.osa.tlog.promotion trans

© sap.is.retail.posdmext.osa.status log view

O sap.is.retail.posdmext.osa.reporting.MON ANA VIEW

© sap.is.retail.posdmext.osa.reporting.STATUS LOG VIEW

7. Verify that the following procedures have been activated:

1. Proceduresinthe package sap.is.retail.posdmext.osa.common:
© CREATE LOG ENTRY
© PARSE _HOLIDAY STRING
© PARSE TYPE CODE STRING

2. Proceduresinthe package sap.is.retail.posdmext.osa.tlog.dao:

© GET TRX FOR PRODUCT

CUSTOMER

© Copyright 2015 SAP SE or an SAP affiliate company. ©

SAP Customer Activity Repository 2.0 SPO1 Copyright 2015 SAP SE or an SAP affiliate company.
Follow-Up Activities All rights reserved.All rights reserved. 33



34

3. Proceduresinthe package sap.is.retail.posdmext.osa.pattern.dao:
o PERSIST
© GET_INTRA WEEK PATTERN RUNS
© GET INTRA WEEK PATTERN LATEST
© GET_INTRA WEEK PATTERN
© GET_INTRA WEEK PATTERN FOR_PRODUCT
4. Proceduresinthe package sap.is.retail.posdmext.osa.pattern.runner.internal:
o CALL FUNCTION
© CALL ALGO FOR STORE
© CALL ALGO FOR_SUBDEP
© CALL ALGO_PRODUCT IN_ SUBDEP
5. Proceduresinthe package sap.is.retail.posdmext.osa.pattern.runner.public:
© RUN_FOR_PRODUCT IN SUBDEP
© RUN_FOR_STORE
© RUN_FOR_SUBDEP
6. Procedureinthe package sap.is.retail.posdmext.osa.pattern.test:
© TEST I INTEGRATION
7. Procedure in the package sap.is.retail.posdmext.osa.estimation.config:
© GET_CONFIG
8. Proceduresinthe package sap.is.retail.posdmext.osa.estimation.dao:
o PERSIST
o GET PARAMETER
o GET PARAMETERS
9. Proceduresinthe package sap.is.retail.posdmext.osa.estimation.runner.internal:
© CALL FUNCTION
© CALL ALGO PRODUCT IN SUBDEP
10. Procedure inthe package sap.is.retail.posdmext.osa.estimation.runner.public:
© RUN FOR PRODUCT IN SUBDEP
11. Procedurein the package sap.is.retail.posdmext.osa.estimation.test:
© TEST I INTEGRATION
12. Procedures inthe package sap.is.retail.posdmext.osa.monitor.dao:
0 PERSIST
© CREATE STATUS LOG ENTRIES
© UPDATE_STATUS TABLE
© CREATE STATUS LOG ENTRIES FOR_EXCIL, PRODUCTS
CUSTOMER
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14.

15.

16.

17.

18.

19.

© UPDATE STATUS TABLE FOR_EXCL PRODUCTS

Procedures in the package sap.is.retail.posdmext.osa.monitor.runner.internal:
© CALL FUNCTION

© CALL ALGO_ PRODUCT_ IN SUBDEP

© RUN _FOR PRODUCT IN SUBDEP

Procedures in the package sap.is.retail.posdmext.osa.monitor.runner.public:

© GET QUALIFIED PRODUCT FOR RUNNER

© RUN_MONITOR

Procedure in the package sap.is.retail.posdmext.osa.monitor.test:

] TEST L INTEGRATION

Procedure in the package sap.is.retail.posdmext.osa.analysis.calc:

o COMPUTE LOST SALES

Procedure in the package sap.is.retail.posdmext.osa.analysis.dao:

O PERSIST

Procedures in the package sap.is.retail.posdmext.osa.analysis.runner.internal:
© CALL FUNCTION

© CALL ALGO_PRODUCT TN SUBDEP

Procedure in the package sap.is.retail.posdmext.osa.analysis.runner.public:

© RUN_FOR PRODUCT IN SUBDEP

5.5.6 Configure SAP NetWeaver Gateway and Activate OData

Service

This configuration step is only required if you use separate products or developments on top of SAP Customer
Activity Repository that communicate via OData service. After you have installed SAP NetWeaver Gateway,
configure the Gateway system and configure the settings for OData service.

Procedure

The main steps to do this are as follows:

1. Activate SAP NetWeaver Gateway.
2. Define RFC connections from SAP NetWeaver Gateway to your back-end system.
3. Define settings for OData service for the SAP NetWeaver Gateway.
4. Define settings for Push Functionality (optional).
5. Setup users and Authorizations for SAP NetWeaver Gateway.
6. Activate the OData Service in the SAP NetWeaver Gateway system (transaction /IWFND/maint service)
for the requested URI (for example: /sap/opu/sdata/OSA/ON_SHELF AVAILABILITY/).
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For detailed information, see SAP Library for SAP NetWeaver Gateway on SAP Help Portal at ¢ help.sap.com/
nwgateway » Application Help » Support Package 06 » SAP NetWeaver Gateway Developer Guide » OData
Channel 3.
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